Delay in CODA from Crelan

Incident Report for CodaBox

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 16:04 CEST

Monitoring

CODA from Crelan arrived. Delivery will happen during the day
Posted Jul 02, 2026 - 11:35 CEST

Investigating

Crelan CODA did not arrive yet. We are in contact with the bank.
Posted Jul 02, 2026 - 09:55 CEST
This incident affected: CODA (Crelan Coda).