Delay in CODA from Crelan

Incident Report for CodaBox

Monitoring

Crelan confirmed the missing CODA will be delivered the coming hours.
Posted Mar 27, 2026 - 16:03 CET

Investigating

We are currently investigating this issue.
Posted Mar 27, 2026 - 08:19 CET
This incident affects: CODA (Crelan Coda).