Delay in CODA for Crelan

Incident Report for CodaBox

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 08:17 CEST

Identified

We're processing the delayed files.
Posted Sep 11, 2025 - 14:43 CEST

Update

We are continuing to investigate this issue.
Posted Sep 11, 2025 - 13:21 CEST

Investigating

We are currently investigating this issue.
Posted Sep 11, 2025 - 10:14 CEST
This incident affected: CODA.